Logiska funktioner i Excel

De logiska funktionerna i Excel ger dig möjlighet att avgöra om en cell har ett specifikt värde som du "frågar den" och beroende på om det är sant eller falskt så returnerar den tillbaka ett förutbestämt värde. Det kan exempelvis vara att om det står EUR i en cell vill du multiplicera en annan cell med 10,8, men om om det står DKK vill du multiplicera med 1,45

Lär dig mer om detta nedan:

5 funktioner att gå igenom

  1. =OM ställer och kontrollerar ett villkor och returnerar "Sant" eller "Falskt"

  2. Dubbel =OM innebär att om första =OM funktionen visar "Falskt" så skriver du en ny om och testar ett nytt villkor

  3. =OMFEL innebär att om en funktion skulle returnera ett felvärde så bestämmer du vad som ska stå, som 0 eller blanksteg

  4. =OCH innebär att flera villkor måste uppfyllas för "Sant"

  5. =ELLER innebär att minst ett av flera villkor måste uppfyllas för "Sant"

01/ =OM (Eng. IF)

=OM kontrollerar om ett villkor uppfylls. Om villkoret uppfylls returneras ett värde, om inte returneras ett annat

Vi har de tre argumenten:

Logiskt test ;

Värde om logiska testet är sant ;

Värde om logiska testet är falskt

Första argumentet kan exempelvis vara "Om det står DKK i cell A1", det skrivs genom =OM(A1="DKK"...

Andra argumentet är vad som ska hända om det står DKK i A1, exempelvis vill vi då multiplicera A1 med 1,45.
=OM(A1="DKK";A1*1,45

Tredje argumentet kan vara att om det inte står DKK i A1 vill vi att 0 returneras.
=OM(A1="DKK";A1*1,45;0)

Tips

  1. Om du skriver 1,45 i en cell och vid "Sant" vill multiplicera med cellen, var noga med att referensen är absolut med $
    =OM(A1="DKK";A1*$K$4;0)  <-- Säg att K4 har värdet 1,45. När du drar cellen neråt kommer inte K4 att ändras

  2. Text skrivs alltid inom citattecken

02/ Dubbel OM

I =OM:s tredje argument...

Värde om logiska testet är falskt

... sätts en ny =OM-formel. Då blir det två olika villkor som testas

=OM(A1="DKK";A1*1,45;OM(A1="EUR";A1*10,8;0))

03/ =OMFEL (=IFERROR)

=OMFEL ger möjlighet att bestämma värde om en funktion skulle returnera ett felvärde

Vi har de två argumenten:

Formel som kan ge "error" ;

Värde om formeln visas "error"

=OMFEL(1/0;0)

Det går inte att dela med 0, vilket vanligtvis skulle ge "error", men nu returneras värdet 0 istället

Tips

  1. Ha för vana att skriva =OMFEL i början av en funktion om risk för felvärden kan inträffa, ex om du gör en LETARAD-funktion

  2. Två bra värden för det andra argumentet är

    • 0​

    • "" <-- d.v.s. tomt

04/ =OCH (=AND)

=OCH returnerar antingen "Falskt" eller "Sant", där alla argument måste uppfyllas

Vi har argumenten:

Villkor 1 ;

Villkor 2 ;

O.s.v.

=OCH(A3<1;A33>-1)

Värden mellan -1 och 1 i cell A3 kommer returnera SANT, allt annat kommer resultera FALSKT

Tips

  1. =OCH kan användas inom en =OM-funktion för att se till att flera villkor måste uppfyllas för din OM-funktion
    =OM(OCH(E3>0;K4="DKK")...  <-- Här krävs både att cell E3 är större än 0 och att det står DKK i cell K4

05/ =ELLER (=OR)

=ELLER returnerar antingen "Falskt" eller "Sant", där minst ett av argumenten måste uppfyllas

Vi har argumenten:

Villkor 1 ;

Villkor 2 ;

O.s.v.

=ELLER(A1=1;A1=2)

Om A1 är 1 eller 2 kommer formeln att returnera SANT, allt annat kommer resultera i FALSKT

Tips

  1. =ELLER kan användas inom en =OM-funktion:
    =OM(ELLER(A1=1;A1=2)...  <-- Om A1 har värdena 1 eller 2 så händer något (SANT), annars händer något annat (FALSKT), som du definierar vidare i din OM-funktion

Excel med Rickard