Summera rätt i Excel

Vad händer när du summerar med =SUMMA celler i en kolumn med bort-filtrerade värden? Jo, de summerar även de bort-filtrerade värdena och =DELSUMMA bör användas istället. Du kan även komma att vilja summera värden baserat på villkor, ex summera alla värden i B-kolumnen om det står "Banan" i A.

Lär dig mer nedan:

5 funktioner att gå igenom

  1. =SUMMA summerar samtliga celler som markeras, dolda som icke-dolda

  2. =DELSUMMA returnerar en delsumma i en lista

  3. =SUMMA.OM som summerar baserat på ett villkor

  4. =SUMMA.OMF som summerar baserat flera villkor

  5. Summera samma cell(er) i flera flikar

01/ =SUMMA (Eng. =SUM)

=SUMMA adderar samtliga celler som väljs ut

Vi har argumenten:

Tal 1 ;

Tal 2 o.s.v.

=SUMMA(A1:A2;B1:B2)

Ovan summerar cellerna A1 + A2 + B1 + B2

02/ =DELSUMMA

Returnerar en delsumma av de celler som väljs, där bortfiltrerade värden alltid utesluts.

Vi har argumenten:

Val av funktion ;

Tal 1 ;

Tal 2 o.s.v.

Funktionen i första argumentet kan vara (ej fullständig lista):

1 - MEDEL

2 - ANTAL

3 - ANTALV

9 - SUMMA

=DELSUMMA(9;A2:A10)

Ovan summerar cell A2:A10 och räknar inte med bortfiltrerade celler

=DELSUMMA(1;A2:A10)

Ovan räknar ut medelvärdet av cell A2:A10

03/ =SUMMA.OM

=SUMMA.OM summerar celler baserat på ett villkor

Vi har de tre argumenten:

Område att leta efter villkor i ;

Villkor att leta efter ;

Område med celler att summera

=SUMMA.OM(A:A;"Äpple";B:B)

Ovan summerar kolumn B om det står Äpple i kolumn A. Ex står "Äpple" i A1 och A2 kommer värdet av det som står i B1 + B2 att returneras.

TIPS: Det andra argumentet kan med fördel vara en cell, ex C2 och när du drar ner formeln så blir det C3 o.s.v.

04/ =SUMMA.OMF

=SUMMA.OMF summerar celler baserat på ett eller flera villkor

Vi har argumenten:

Område med celler att summera ;

Område att leta efter villkor i ;

Villkor i att leta efter (Om du vill;

Område att leta efter villkor i ;

Villkor i att leta efter)

=SUMMA.OMF(B:B;A:A;"Äpple")

Samma resultat som ovan, summer kolumn B om det står Äpple i kolumn A, skrivs dock i en annan ordning. Skrivs semikolon efter "Äpple" kan fler villkor läggas till

05/ Summera samma celler

Om du vill summera samma cell eller celler i flera flikar direkt så:

1. Ställ dig i den cell där du ska ha värdet

2. Skriv din summa formel och välj cellerna i den första fliken

3. Innan utropstecknet skriver du kolon + den sista flikens namn

TIPS:

Börja med en start- och stopflik

Detta för att veta mellan vilka flikar det gäller om du skulle behöva ändra ordning eller lägga in nya flikar

Excel med Rickard