INDIREKT (eng. INDIRECT)

Funktionen returnerar referensen som anges av en textsträng. Vad innebär det?

Jo - säg att där står "A1" i cell B1. Referensen i cell B1 är alltså A1 och värdet i cell A1 kommer att returneras om du skriver =INDIREKT(B1). Detta ger möjlighet till:

  • Returnera sista cellen i en kolumn eller rad oavsett rad- eller kolumnantal

  • Referera till andra flikar baserat på cellvärde

  • Namnge celler och referera till dessa. Du kan i så fall antingen summera namngivna celler eller använda en LETARAD-funktion på flera diagram samtidigt

  • Skapa en drop-down list på en drop-down list

Våren/sommaren 2020 släpper jag en Youtube-video på Excel med Rickard om detta, som läggs ut här också. Subscriba för att inte missa! Tills vidare - se nedan:

01/ Definition

=INDIREKT returnerar referensen som anges av en textsträng

  1. Referensen måste vara av A1 eller R1C1 format

  2. Det kan även vara ett namn som definerats som en referens

Till höger så har vi:

  • Cell A1, som också kan skrivas R1C1 d.v.s Row 1 Column 1

  • Cellen har även namngetts till "Banan". Skriver vi =INDIREKT("Banan") kommer värdet i cell A1 att visas

02/ Två argument

Referenstext ;

A1 eller R1C1 format

Det andra argumentet är valfritt. Om inget skrivs så blir det alltid A1. FALSKT måste anges om du vill ha R1C1 format

Båda nedan refererar till värdet som står i cell A1, den ena med A1-format och den andra med R1C1-format

03/ Exempel 1 - Summera namngivna celler

1. Markerade celler har namngetts till "Exempel" genom att först klicka på dem och sedan i rutan där det står Exempel och där döpt dem

2. Formeln =SUMMA(INDIREKT("Exempel")) ger värdet 10 (1+2+3+4)

3. Formeln =ANTAL(INDIREKT("Exempel")) ger värdet 4 (1+1+1+1)

04/ Exempel 2 - Referera till flik med samma namn som står i cell

I den översta bilden så summerar vi cell D3:D14 i fliken "Exempel". Tecknet ' skrivs innan och efter fliknamnet men behövs enbart om fliken är mer än ett ord eller innehåller ett specialtecken eller en siffra

 

I den andra bilden så gör vi samma sak, fast med en indirekt-formel. Vår referens som anges i textsträngen skrivs inom citattecken och är en referens som ser ut på exakt samma sätt som i första rutan

Låt säga att vi skriver Exempel i cell A1. Vi kan då få samma resultat om vi skriver som i bild 3. Det vi gör är att vi skriver all text inom citattecken och lägger till med &-tecken cell-refereringar. Det kommer nu stå:

' + Exempel (värdet i A1) + '!D3:D14 <-- vilket är samma som i de två ovan.

Du kan nu ändra värdet i A1 för att snabbt summera D3:D14 i en annan flik

05/ Exempel 3 - Indirekt + Letarad (vlookup)

Hämta värdet för det land och den månad som står i C6 & C7:

Döp varje kolumn till landet - som du ser att Tyskland blivit döpt ovan. Referensen med indirekt "Tyskland" kommer då vara cellerna E2:E14.

När du gör din LETARAD-funktion så byter du bara ut det andra argumentet mot en indirektformel som pekar mot C7.

=LETARAD(C6;INDIREKT(C7);2;FALSKT)

Byter du månad eller land kommer nu värdet att reflektera detta.

06/ Exempel 4 - Hämta sista värdet i en kolumn eller rad

För att hämta sista värdet i en rad krävs att du skriver i R1C1-format d.v.s. att cell A1 skrivs som R1C1 (Row 1, column 1).

Sista cellen i ex rad tre, juli månad, blir R3C8. Tänk dig att du lägger till en månad, augusti, då blir C = 9. Du kan således skriva en formel, ex ANTALV i rad 3 (antal ej tomma celler) istället för siffran 9. Detta måste göras med en indirekt-formel.

=INDIREKT("R3C"&ANTALV(3:3);FALSKT)

Det som det nu står är referensen: R3C + siffran för så många ej tomma celler som finns i rad 3, d.v.s 8 i detta fall

07/ Exempel 5 - Skapa en drop-down list på en drow-down list

Få en drop-down list på städer baserat på land i E7

I E7 vill du få upp alternativen: Tyskland, England och Sverige.

I E8 vill du få upp de städer som finns i det land som valts i E7.

Ex: Väljer du England vill du få upp London, Liverpool och Manchester.

Under menyraden "Data" och sedan "Dataverifiering" hittar du ovan ruta. Välj lista och källan är de cellvärden som ska tillåtas. I detta fallet värdena som står i cell B2:H2, alltså där länderna Tyskland, England och Sverige står

I E8 gör du istället en INDIREKT--formel i källan som pekar mot E7.

OBS: Städerna måste ha blivit namngivna innan, se nedan

Excel med Rickard

Excel med Rickard